[Pardus 2011.3 experimental] Pardus 2011.2 x86_64 con Firefox 10, Kernel 3.2.2 y KDE 4.8 – Howto


A pesar de que oficialmente no habrán más actualizaciones para Pardus 2011, como ya vimos en la entrada anterior, Pardus aún no está muerta. La comunidad de Pardus no se resigna a perder a su distro favorita y se está moviendo, algo que también comenté en la anterior entrada.

A través del foro Turco me he tropezado con este tutorial en el blog de Kaan Akşit donde nos comenta como actualizar nuestra Pardus 2011.2 al Kernel 3.2.2, tener el Firefox 10 y el nuevo KDE 4.8. Lo que podría llamarse una “Pardus 2011.3 experimental”

ADVERTENCIA: Solo para valientes. Yo no lo he probado pues en estos momentos solo tengo Pardus 32-bit así que no puedo garantizar que funcione al 100% o que no lo haga. Queda en responsabilidad del usuario llevar a cabo o no el tutorial

El tema es que con el nuevo kernel tienen que compilarse los drivers privativos nvidia o ati (el que los use) así como otros drivers privativos que estemos usando. Esto podría ocasionar una pantalla negra al inicio… esto lo digo mas o menos según entiendo de la traducción turco – español

Por eso esto es solo para valientes que no les importe correr este riesgo…..

Y después de la consabida advertencia vamos a ver los pasos a seguir:

Lo primero es agregar el repositorio devel, desactivar el repositorio normal de Pardus y actualizar la distro. Seguimos las órdenes una a una.

sudo pisi ar pardus-devel http://packages.pardus.org.tr/pardus/2011.2/devel/x86_64/pisi-index.xml.xz
sudo pisi dr pardus
sudo pisi er pardus-devel
sudo pisi up

Ahora hay que descargarse el KDE 4.8 desde Dropbox, esto llevará tiempo pues es más de un giga, paciencia…

wget -r http://dl.dropbox.com/u/60411669/index.html

Luego entramos a ese directorio e instalamos todos los paquetes bajados, rezen lo que sepan…..

cd dl.dropbox.com/u/60411669/
sudo pisi dc
sudo pisi clean
sudo pisi it *.pisi --ignore-file-conflicts --ignore-package-conflicts

Aquí el tema complicado serían los posibles conflictos entre paquetes. Como dije antes, yo no lo he probado así que no se como irá la cosa

La instalación llevará un buen rato y si todo haya ido bien tendremos nuestra “Pardus 2011.3 experimental”

Recuerden que todo esto es posible gracias a la comunidad que se ha esforzado en empaquetar el software más subirlo a Dropbox …etc

Un vídeo demostrativo de este usuario al que parece le funciona😉

RECUERDEN: Esto es solo para Pardus 64-bits y para los más atrevidos, queda en la responsabilidad del usuario llevarlo o no a la práctica, no me responsabilizo de posibles errores si los hubiere en caso de que decidan aventurarse…

ACTUALIZACIÓN: Nuestro amigo, isezen, un entusiasta de Pardus, nos deja en los comentarios un par de notas a tener en cuenta, las agrego en el artículo pos si hicieran falta

1 – Es posible que se tengan problemas de sonido después de la instalación, para arreglarlo hacemos:

sudo pisi bi https://svn.pardus.org.tr/pardus/playground/kaan.aksit/2011/kernel/default/drivers/module-alsa-driver/pspec.xml
sudo pisi it *.pisi
rm -Rf *.pisi

2 – Si hay problemas con los controladores privativos gráficos, se deben construir los nuevos .pisi para agregarlos al nuevo kernel. Visiten este otro artículo donde se menciona el procedimiento a seguir

Para una información más ampliada pueden visitar la fuente, en Turco | Pardus 2011.2 x86-64′e Firefox 10, KDE 4.8 ve Çekirdek 3.2.2 sürümlerini yüklemek yani bir nevi Pardus 2011.3 kurmak (deneysel)

Si alguien lo prueba que nos cuente como le fue🙂

Enjoy😉

27 pensamientos en “[Pardus 2011.3 experimental] Pardus 2011.2 x86_64 con Firefox 10, Kernel 3.2.2 y KDE 4.8 – Howto

  1. miansancor

    ¡Gracias Yoyo, paisano por la noticia!
    ¡Madre mía es un poco tentador! Pero me espero a que alguien lo pruebe y nos diga si no le ha “estallado” el PC, además yo teniendo un iMac con una nvidia algo especial…. No me atrevo, pero, repito, gracias por la noticia, pues da esperanza a esta distro dada por muerta. Tal y como está va muy bien…

    Responder
  2. isezen

    Hola amigos Pardususeros,🙂

    I stricly recommend that this is an experimental workaround and please be carefull on some points.

    1- You may have sound problem after installation, to overcome this:
    sudo pisi bi https://svn.pardus.org.tr/pardus/playground/kaan.aksit/2011/kernel/default/drivers/module-alsa-driver/pspec.xml
    sudo pisi it *.pisi
    rm -Rf *.pisi

    2- If you have closed source graphics card driver, or something else for any hardware, please remember you must build pisi files for those drivers on new kernel. That means the build process must be accomplished on new kernel. And Kaan asks inform him if you meet a case like this, and he said that he will be glad to help you as he can.

    Please, stick to this post, if you have problem with new kernel.
    http://kaanaksit.wordpress.com/2012/01/17/tr-pardus-2011-2e-3-2-0-surum-linux-cekirdegini-kurmak/

    Responder
  3. chimini

    Me fue bien, lo unico es que pardus sigue sin reconocerme el sistema de refrigeración, tengo que pasarle el parametro acpi=off y sale en algunos casos el mismo error que sale en el fedora con kde y graficos de Nvidia o ati que falla el Klinit, El Knotify, pero el solo al principio de resto todo se va bien con el sistema.
    PDT: si usan smoot-task no lo hagan hasta que desinstales este, porque se tira el entorno, es preferible que lo desinstales y instalen icon-task este si es compatible con el KDE-4.8 el otro no y es un problema racuperar el sistema despues de eso porque no inicia el entorno grafico.
    Si de todas formas les pasa por unt TTY ingrsan como Root, desinstalan smoot-task y solucionado el problema.

    Responder
  4. Yoyo Autor de la entrada

    Gracias por el dato, chimini

    Lo tomaremos en cuenta😉

    Por cierto, he actualizado el artículo con la nueva info que nos dejó en los comentarios el amigo isezen

    Saludos

    Responder
  5. Pingback: Pardus KDE4.8 Kernel 3.2.2 Firefox 10

  6. miansancor

    Pero ahora tengo una pregunta, este repositorio que nos has indicado, se rije por los mismos parámetros del otro. Quiero decir ¿las órdenes necesarias son las mismas?:

    1 cd dl.dropbox.com/u/1836567/
    2 sudo pisi dc
    3 sudo pisi clean
    4 sudo pisi it *.pisi –ignore-file-conflicts –ignore-package-conflicts

    Pues he visto, que hay más paquetes a parte de los de kde 4.8 y los del kernel y no creo que sea necesario instalarlos todos ¿O me equivoco?

    Responder
    1. Yoyo Fernández Autor de la entrada

      Para bajar los paquetes con wget habrías de cambiar la dirección de la cuenta de dropbox a la nueva, sería esta, si no me equivoco

      wget -r http://dl.dropbox.com/u/1836567/Paketler/kde-4.8-pisi/index.html

      Luego entras a al directorio donde se hayan bajado y sigues las mismas instrucciones

      Respecto al kernel si antes habíaa que instalarlo supongo que ahora también, ahora está el 3.2.5 y antes era el 3.2.2

      Respecto a instalar todos los paquetes, pues no se, tu mismo, es cierto que hay más de los que habían en la otra cuenta. Yo no he probado el tutto y solo te puedo decir que tu mismo, si quieres experimentar pues adelante y si no pues te esperas a la Pardus 2012

      Grrrr que tensión xDD

      Responder
      1. miansancor

        ¿Va a ver una pardus 2012? ¿Quien la está preparando si la empresa oficial de Pardus ya no le interesa seguir con ella?
        ¡Gracias por la información!

      2. Yoyo Fernández Autor de la entrada

        Hola, miansancor

        Se supone que cuando terminen la re-estructuración tienen que seguir con Pardus, entonces lo más lógico es esperar una Pardus 2012

        Un saludo

  7. miansancor

    me he atrevido y lo he realizado siguiendo las instrucciones pero he instalado primero el kernel y los módulos del 3.2. ¡HA IDO BIEN! No he tenido problemas ni con el sonido ni con la gráfica (intel HD).
    Ahora estoy con la instalación del kde 4.8, el primer error era que no se satisfacian las dependencias de akonady así que añadí:

    sudo pisi it *.pisi –ignore-file-conflicts –ignore-package-conflicts –ignore-dependency

    se está instalando bien, pero no sé como ira al final después del primer reinicio… Lo que es la instalación no ha dado errores, pero claro con todas las órdenes de “ignorar” no era para menos. Ya os diré. Voy a reiniciar…
    Saludos a todos

    Responder
    1. Yoyo Fernández Autor de la entrada

      Hemos escrito a la vez, arriba te contestaba a tu otro comentario pero veo que ya te has lanzado así que solo nos queda esperar a que nos cuentes como fué el invento

      Suerte!!!!

      Responder
  8. miansancor

    Gracias Yoyo, por tu respuesta. Es que aprovecho que ahora tenía una buena conexión a internet y lo he intentado.
    Te puedo decir que mi portatil no ha “explotado” y funciona bien – hasta ahora – el kernel es:

    uname -a Linux pardus-Acer-5733Z 3.2.2 #1 SMP Wed Feb 1 17:24:43 EET 2012 x86_64 x86_64 x86_64 GNU/Linux

    El problema que encuentro es que el sistema me pide de actualizar, pero en realidad lo que intenta es volver a las versiones previas ¿Cómo puedo hacer al respecto? Hay algún modo de crear un repositorio pisi local, añadiendo los paquetes de http://dl.dropbox.com/u/1836567/Paketler/*.*

    ¿Tiene un momento para chatear?
    ¡Gracias por tu ayuda!

    Responder
    1. Yoyo Fernández Autor de la entrada

      Hoy estamos experimentando y descubriendo cosas nuevas jajajaja

      Veamos, si lo hay, crea un repo local en tu /home con todos los paquetes que te has bajado y añadelo a Pardus. Gracias al compa paranoid sabemos como hacerlo😉 http://www.pardus-es.net/t553-how-to-creando-nuestro-propio-repositorio-para-pardus#4341

      Con eso supongo que ya verá esos paquetes más recientes y no te pedirá actualizar

      Ahora otra cosa, acá tienes el kernel más nuevo, 3.2.5 más los módulos del kernel, drivers gráficos etc ¿te sigues atreviendo? xDD http://home.ku.edu.tr/~kaksit/2011/x86_64/

      Acá tienes el link original del foro Turco, usa google translator para aclararte http://www.pardus-linux.org/forum/yaz%C4%B1l%C4%B1m/kde-480-paketlerini-denemek

      [Vaya gazpacho estamos liando, espero no explote todo y destruyas Granada]

      Responder
  9. miansancor

    Bueno Yoyo, de nuevo gracias por tus sugerencias. Estoy bajando los pisi para intentar actualizar el kernel – esperemos que no explote nada – Mi problema sigue siendo la imposibilidad de añadir el repositorio local y que se actualice el sistema automaticamente sin que me pida de volver a las versiones anteriores ¿Alguna idea al respecto?
    ¡Gracias Yoyo!

    Responder
  10. miansancor

    Gracias Yoyo, también paran0id me ha respuesto en el foro y aunque he seguido el tutorial del inicio de este post y he quitado los repositorios oficiales los que tengo son el pardus-devel – user.de – CoMak – PardusLife – My-Repo.
    He intentado reconstruir la base de datos pisi (pisi rdb) pero SIEMPRE me sale que hay paquetes para actualizar y son el kernel y kde anterior
    ¿Alguna otra idea? ¡Gracias!

    Responder

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s